티스토리 뷰

공장 (factory)/- Errors

[Ant] BUILD FAILED, Class not found: javac1.8

공부하는 나부랭이, 무중력고기 2014.04.07 20:30



   빌드하려는데 에러가 났다.


   처음엔 Ant를 써보지 않아서 사용 미숙으로 나는 에러인 줄 알았다.


   그러나 찾아보니 Java 1.8 버전을 지원하지 않아서 나는 에러.. ㅡ.ㅡ;;


   1.8 버전이 나왔길래 좋~다고 설치했는데.. 여기서 막힐 줄이야. ㅡㅡ....


   개발할 때 1.6 버전으로 해당 프로젝트 버전 맞춰서 개발했던 적이 있는데, 이것저것 상위 버전에만 있는 라이브러리들을 따로 다운 받아 설치해야 하는 번거로움 때문에 설치는 1.7 버전으로 하고 컴파일을 1.6이나 1.5에 맞춰서 하는 방식을 택했었다. 그래서 이번에 컴터 다시 세팅할 때도 그런 것을 염두에 두고 가장 최신 버전인 1.8을 설치했던 것이다. 근데 1.8이 너무 최신이라 이런 데에서부터 막히니.. ㅜㅜ


   1.7 버전 설치하고 이클립스에서 Preferences → Java → Installed JREs 에서 Add해줘도, 프로젝트 컴파일 버전을 바꿔줘봐도 정신 못차리길래 아예 프로젝트를 새로 1.7로 생성해서 옮겼더니 잘 돌아간다.


   얼른 1.8에 맞춰서 업그레이드 해달라고!!!....요..........;;



댓글
댓글쓰기 폼
Total
1,174,190
Today
347
Yesterday
1,182
«   2018/12   »
            1
2 3 4 5 6 7 8
9 10 11 12 13 14 15
16 17 18 19 20 21 22
23 24 25 26 27 28 29
30 31          
글 보관함